Перейти к содержимому


Фотография

не все плагины работают


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 6

#1 Cyber Freak

Cyber Freak

    Новичок

  • Пользователь
  • Pip
  • 17 сообщений

Отправлено 15 Апрель 2023 - 11:31

всех приветствую

использую я выделенный сервер, но не все плагины у меня включаются

часть работает, но вот загрузил я github плагин под названием skill detect он почему-то в упор не пашет.

в чем проблема?


  • DavidVop это нравится

#2 dr_lex

dr_lex

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 1 053 сообщений

Отправлено 16 Апрель 2023 - 1:48

всех приветствую

использую я выделенный сервер, но не все плагины у меня включаются

часть работает, но вот загрузил я github плагин под названием skill detect он почему-то в упор не пашет.

в чем проблема?

Прочитайте свое сообщение как от постороннего человека. Вам будет понятно что написано в сообщении?

Я понял только что "у вас не все плагины работают" и "взяли из github плагин skill detect".
Какую помощь вы ожидаете увидеть по такой информации? Или по вашему у всех точно такие же сборки сервера как у вас?)

=====================

Проблема многих пользователей в том, что они не знают как объяснить свою проблему и создают темы мусора (спама). Понятно что так быстрее, а потом начинают бомбить ЛС пользователей форума. А надо просто правильно дать информацию о своей проблеме!
 

 

Cyber Freak отослал вам запрос на добавление в список друзей
мар 28 2023 12:39

 

По этому у меня отключен ЛС на форуме и смысла добавляться в друзья нет!

Хотите решение то дайте больше информации, например что показывает в консоли сервера данные команды:

plugin_print
meta list
sm exts list
sm plugins list

Это базовая информация от которой можно уже что-то понять или увидеть.

Так же логи из папки (если они есть).

/addons/sourcemod/logs

А так можете дальше ждать помощи или искать решение сами как слепой котенок!
 


Сообщение отредактировал dr_lex: 16 Апрель 2023 - 1:50


#3 BloodyBlade

BloodyBlade

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 1 117 сообщений

Отправлено 16 Апрель 2023 - 8:15

всех приветствую

использую я выделенный сервер, но не все плагины у меня включаются

часть работает, но вот загрузил я github плагин под названием skill detect он почему-то в упор не пашет.

в чем проблема?

Приветствую. Отгадка на ваш вопрос кроется в исходнике. Плагин не будет работать без запрашиваемых им ещё при компиляции доп. плагинов.



#4 Cyber Freak

Cyber Freak

    Новичок

  • Пользователь
  • Pip
  • 17 сообщений

Отправлено 16 Апрель 2023 - 15:11

dr_lex, :

 

 

plugin_print
Loaded plugins:
---------------------
0:      "Metamod:Source 1.11.0-dev+1148"
---------------------
meta list
Listing 4 plugins:
  [01] SourceMod (1.10.0.6545) by AlliedModders LLC
  [02] ProcessCmds (1.1.1) by GoDtm666 (www.MyArena.ru)
  [03] SDK Tools (1.10.0.6545) by AlliedModders LLC
  [04] SDK Hooks (1.10.0.6545) by AlliedModders LLC

sm exts list
[SM] Displaying 12 extensions:
[01] Automatic Updater (1.10.0.6545): Updates SourceMod gamedata files
[02] Webternet (1.10.0.6545): Extension for interacting with URLs
[03] ProcessCmds (1.1.1): Исправление багов, дополнение к плагинам и проверка на флуд.
[04] SDK Tools (1.10.0.6545): Source SDK Tools
[05] BinTools (1.10.0.6545): Low-level C/C++ Calling API
[06] SDK Hooks (1.10.0.6545): Source SDK Hooks
[07] GeoIP (1.10.0.6545): Geographical IP information
[08] <OPTIONAL> file "geoipcity.ext.so": /game/left4dead2/addons/sourcemod/extensions/geoipcity.ext.so: cannot open shared object file: No such file or directory
[09] Regex (1.10.0.6545): Provides regex natives for plugins
[10] Top Menus (1.10.0.6545): Creates sorted nested menus
[11] Client Preferences (1.10.0.6545): Saves client preference settings
[12] SQLite (1.10.0.6545): SQLite Driver

sm plugins list
[SM] Listing 30 plugins:
  01 "Skill Detection (skeets, crowns, levels)" (0.9.19) by Tabun
  02 <Failed> "Vocalize Anti-Flood" (1.0.2) by Buster "Mr. Zero" Nielsen
  03 "Connect Announce" (1.8) by Arg!
  04 "L4D Vote Manager 2" (1.5.7) by Madcap
  05 "L4D2 Pause" (0.2.1) by pvtschlag
  06 <Error> "Simple Player Statistics" (1.0.1-alpha) by mac & cheese (a.k.a thresh0ld)
  07 "L4D2 Set Survivor Model" (1.0.2) by AtomicStryker
  08 "Admin Sprays Only" (1.25) by luki1412
  09 "L4D Friendly Fire damage remover" (1.3.0) by R-Hehl
  10 "Show Damage" (1.0.7) by exvel
  11 <Bad Load> antiflood.smx
  12 <Bad Load> clientprefs.smx
  13 <Bad Load> sounds.smx
  14 <Bad Load> basebans.smx
  15 <Bad Load> nextmap.smx
  16 <Bad Load> basevotes.smx
  17 <Bad Load> playercommands.smx
  18 <Bad Load> adminhelp.smx
  19 <Bad Load> basechat.smx
  20 <Bad Load> adminmenu.smx
  21 <Bad Load> funcommands.smx
  22 <Bad Load> l4d_vocalize_antiflood.smx
  23 <Bad Load> basecommands.smx
  24 <Bad Load> reservedslots.smx
  25 <Bad Load> l4d2_stats.smx
  26 <Bad Load> admin-flatfile.smx
  27 <Bad Load> no_friendly-fire.smx
  28 <Bad Load> funvotes.smx
  29 <Bad Load> basecomm.smx
  30 <Bad Load> basetriggers.smx
Errors:
vocalizeantiflood.smx (Vocalize Anti-Flood): Could not find required plugin "sceneprocessor"
l4d2_simpleplayerstats.smx (Simple Player Statistics): Error detected in plugin startup (see error logs)
antiflood.smx: Unable to load plugin (unsupported feature set; code is too new)
clientprefs.smx: Unable to load plugin (unsupported feature set; code is too new)
sounds.smx: Unable to load plugin (unsupported feature set; code is too new)
basebans.smx: Unable to load plugin (unsupported feature set; code is too new)
nextmap.smx: Unable to load plugin (unsupported feature set; code is too new)
basevotes.smx: Unable to load plugin (unsupported feature set; code is too new)
playercommands.smx: Unable to load plugin (unsupported feature set; code is too new)
adminhelp.smx: Unable to load plugin (unsupported feature set; code is too new)
basechat.smx: Unable to load plugin (unsupported feature set; code is too new)
adminmenu.smx: Unable to load plugin (unsupported feature set; code is too new)
funcommands.smx: Unable to load plugin (unsupported feature set; code is too new)
l4d_vocalize_antiflood.smx: Unable to load plugin (unsupported feature set; code is too new)
basecommands.smx: Unable to load plugin (unsupported feature set; code is too new)
reservedslots.smx: Unable to load plugin (unsupported feature set; code is too new)
l4d2_stats.smx: Unable to load plugin (unsupported feature set; code is too new)
admin-flatfile.smx: Unable to load plugin (unsupported feature set; code is too new)
no_friendly-fire.smx: Unable to load plugin (unsupported feature set; code is too new)
funvotes.smx: Unable to load plugin (unsupported feature set; code is too new)
basecomm.smx: Unable to load plugin (unsupported feature set; code is too new)
basetriggers.smx: Unable to load plugin (unsupported feature set; code is too new)

BloodyBlade, а где узнать какие доп плагины он хочет?


сегодня утром у меня почему-то слетела админка.

ничего не трогал.

она сама отключилась

при команде sm_admin в игре пишет - command blocked!

добавлял её разными способами, но она не включилась.


Сообщение отредактировал Cyber Freak: 16 Апрель 2023 - 15:13


#5 Cyber Freak

Cyber Freak

    Новичок

  • Пользователь
  • Pip
  • 17 сообщений

Отправлено 16 Апрель 2023 - 18:30

у меня завалена вся папка логов повторными файлами, в основном пишет это:

Unable to load plugin (unsupported feature set; code is too new).
L 04/16/2023 - 14:53:58: Error log file session closed.
L 04/16/2023 - 14:53:58: SourceMod error session started

 



#6 dr_lex

dr_lex

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 1 053 сообщений

Отправлено 16 Апрель 2023 - 19:41

dr_lex, :

 

BloodyBlade, а где узнать какие доп плагины он хочет?


сегодня утром у меня почему-то слетела админка.

ничего не трогал.

она сама отключилась

при команде sm_admin в игре пишет - command blocked!

добавлял её разными способами, но она не включилась.

1. У вас старый SourceMod (1.10.0.6545) версия  SM 1.10 больше года уже не поддерживаются. Обновите версию до SM 1.11 версии и соберите все плагины через актуальный компилятор плагинов.
2. Так же у вас не работают стандартные плагины SM. Скорее всего вы что-то удалили в сборке SM что сломало их работу. И по этому многие функции перестали работать как и плагины
3. Уберите эту хрень и как совет не пользуйтесь с панели Myarena инструментами (кроме эмулятора no-steam).

 [02] ProcessCmds (1.1.1) by GoDtm666 (www.MyArena.ru)

Это бесполезная хрень для сервера (для l4d2 точно).

===============
Я все же выложу чистую сборку для Linux.
Сборка не самой новой версии, но эта версия у меня установлена на сервере и по мне является стабильной.
В самой сборке добавлены уже:

Metamod:Source (1.11.0-dev+1148)
SourceMod (1.11.0.6927)
L4DToolZ (1.1.0.1)
Tickrate_Enabler (1.5)
Source Scramble (0.7.1)
Stripper (1.2.2)
left4dead2.vpk - файл можно удалить, это фикс локализации (убирает английские фразы которые добавили после DLC), на слотовых тарифах лучше файлы .vpk не использовать!

Скачать
На основе этого вы можете уже понимать что нужно точно серверу l4d2 (без лишних файлов)
Если вам нужно будет сам компилятор и для работы на Windows, то скачайте сборку SM Build 6927 от сюда (все плагины придется собрать через компилятор SM 1.11, советую это делать той версии что на сервере). Если что собирать на Windows плагины .smx и ставить их на сервер Linux можно)
 

 


  • Slaven555 это нравится

#7 Cyber Freak

Cyber Freak

    Новичок

  • Пользователь
  • Pip
  • 17 сообщений

Отправлено 16 Апрель 2023 - 20:55

спасибо.




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных