Перейти к содержимому


Фотография

Запуск самп сервера на VDS


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 20

#1 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 27 Февраль 2017 - 19:56

1.ОС: debian-6.0-x86

2.ID 9091.

 

Скрытый текст
 

 

3.

Выделенные ресурсы: 2x3Ghz AMD, RAM 4Gb, Disk 40Gb

 

Я уже все переустанавливал, все равно не запускается. Но у меня получалось запускать, после того как выключил, больше не включался. 


Сообщение отредактировал offi: 27 Февраль 2017 - 19:56


#2 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 27 Февраль 2017 - 20:07

http://forum.myarena...abote/?p=254655



#3 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 27 Февраль 2017 - 20:35

Сделал все как там, все равно не запускается: -bash: ./samp03svr: No such file or directory



#4 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 27 Февраль 2017 - 20:41

samp03svr: No such file or directory

Нет такого файла либо он не исполняемый.

Пробуй:

chmod +x samp03svr

И заново:

./samp03svr


#5 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 27 Февраль 2017 - 21:10

samp03svr: No such file or directory

Нет такого файла либо он не исполняемый.

Пробуй:

chmod +x samp03svr

И заново:

./samp03svr
 
root@vds9091:/home/offistark/samp03# ./samp03svr &
[1] 1739
root@vds9091:/home/offistark/samp03# chmod +x samp03svr
[1]+  Segmentation fault      ./samp03svr
root@vds9091:/home/offistark/samp03# ./samp03svr
Segmentation fault
root@vds9091:/home/offistark/samp03# ./samp03svr &
[1] 1742
root@vds9091:/home/offistark/samp03#
 
 
root@vds9091:~# chmod: cannot access `samp03svr': No such file or directory
> root@vds9091:~#
>
 


#6 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 27 Февраль 2017 - 21:16

Создавай обычного пользователя, заходи под ним и от его имени загружай все файлы и делай все заново.



#7 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 27 Февраль 2017 - 21:25

Создавай обычного пользователя, заходи под ним и от его имени загружай все файлы и делай все заново.

Я и с обычного пользователя все залил, заново сделал: 

 
root@vds9091:~# cd /home/offistark/samp03
root@vds9091:/home/offistark/samp03# chmod +x samp03svr
root@vds9091:/home/offistark/samp03# ./samp03svr &
[1] 1795
root@vds9091:/home/offistark/samp03# ./samp03svr &
[2] 1804
[1]   Done                    ./samp03svr
root@vds9091:/home/offistark/samp03# ./samp03svr &
[3] 1805
[2]   Segmentation fault      ./samp03svr
root@vds9091:/home/offistark/samp03#
 
 
Вот у меня получалось запускать уже, я даже переустанавливал ОС, и делал все точно так же, но не включился.


#8 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 27 Февраль 2017 - 21:34

А в чем смысл запуска подряд нескольких копий одного сервера?



#9 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 27 Февраль 2017 - 21:37

Я не понимаю что эти цифры значат и нажимаю еще, я ваще ничего не понимаю

 

 
root@vds9091:/home/offistark/samp03# ./samp03svr &
[1] 1834


#10 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 28 Февраль 2017 - 0:34

Это PID процесса, под которым запустилось приложение.



#11 w1ck3d

w1ck3d

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 890 сообщений

Отправлено 28 Февраль 2017 - 11:50

Закачивайте архив с сервером через wget либо в настройках Filezilla включите бинарный тип передачи.



#12 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 28 Февраль 2017 - 16:38

Закачивайте архив с сервером через wget либо в настройках Filezilla включите бинарный тип передачи.

Переустановил полностью ОС. Сделал все по гайду с павн инфо. Залил все через FilleZilla с бинарным типом передачи. Перед всем этим я выполнил подготовку вдс, как в теме выше. Запускаю командой 

cd /home/offi/samp03

./samp03svr &

[1] 605
 
Пишет этот PID, но сервер не запускается. Я просто не могу понять. В первый раз все получилось, я делал все точно так же как и было, и так делал заново как вы говорили.

Вот что в server_log

Скрытый текст



#13 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 28 Февраль 2017 - 16:47

Может стоит сперва без плагинов и со стандартным модом попробовать?



#14 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 28 Февраль 2017 - 16:54

Может стоит сперва без плагинов и со стандартным модом попробовать?

Включился. Только как теперь мне свой мод поставить, аккуратно? 

Залил свой мод, опять не включается


Сообщение отредактировал offi: 28 Февраль 2017 - 17:00


#15 admin

admin

    Администратор

  • Администратор
  • 1 319 сообщений

Отправлено 28 Февраль 2017 - 17:02

запусти без символа &

 

вот так ./samp03svr

и посмотри что сервер рпишет

 

 

PS зачем люди берут вдс если не понимают ничего в linux и не хотят гуглить. непонятна....



#16 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 28 Февраль 2017 - 17:36

Скрытый текст

 

 
root@vds9091:/home/ftp/samp03# ./samp03svr
[1]+  Segmentation fault      ./samp03svr
Segmentation fault
 
Я запускал уже вчера со своим модом, хотел подключить бд, вырубил его и больше он не запускался

Так, дело в плагинах было, теперь другая проблема. Не заходит на сервер и мод unknown

И ошибка: [10:43:44] Script[gamemodes/wrp.amx]: Run time error 19: "File or function is not found"

[10:43:44] Number of vehicle models: 0

Сообщение отредактировал offi: 28 Февраль 2017 - 18:45


#17 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 28 Февраль 2017 - 21:02

Поставил Debian 8, теперь не создается server_log и не знаю, где теперь посмотреть ошибку



#18 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 28 Февраль 2017 - 21:16

Зачем тебе именно VDS, а не PRO-тариф, например?



#19 offi

offi

    Новичок

  • Пользователь
  • Pip
  • 13 сообщений

Отправлено 28 Февраль 2017 - 21:26

Зачем тебе именно VDS, а не PRO-тариф, например?

Хотел несколько серверов


Сообщение отредактировал offi: 28 Февраль 2017 - 21:32


#20 w1ck3d

w1ck3d

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 890 сообщений

Отправлено 01 Март 2017 - 11:14

Тогда гугли, все очень известные ошибки у тебя.




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных