Перейти к содержимому


Фотография

Запуск лаунчера


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 13

#1 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 23 Декабрь 2016 - 17:03

Добрый вечер, не подскажите ли, в чем заключается ошибка?
суть заключается, в том, что при прописывании команды:

 
root@vds772:~# cd /root/(Не важно)/

после чего:
 
root@vds772:~/sashok_v3# java -Xmx256M -jar LaunchServer.jar

Лаунчер начинает запускаться, но выдает ошибку: 
 
sashok724's LaunchServer v15.3 (build #34, 04.12.16)
2016.12.23 09:01:50 [INFO] Setting up server script engine bindings
2016.12.23 09:01:50 [WARN] JavaFX API isn't available
2016.12.23 09:01:50 [INFO] JLine2 terminal enabled
2016.12.23 09:01:50 [INFO] Reading RSA keypair
2016.12.23 09:01:50 [INFO]  Modulus CRC32: 0x87aed468
2016.12.23 09:01:50 [INFO] Reading LaunchServer config file
2016.12.23 09:01:50 [ERROR] java.io.IOException: Value start expected (line 31)
 
Не подскажите, как решить? Если надо что-то скачать, то пропишите команду, для скачивания. ;DD
Заранее, спасибо!
 

 



#2 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 24 Декабрь 2016 - 21:58

Нашел решение, но сейчас всплыла другая ошибка. :/

root@vds772:~/sashok_v3# java -Xmx256M -jar LaunchServer.jar 
sashok724's LaunchServer v15.3 (build #34, 04.12.16) 
2016.12.24 12:54:55 [INFO] Setting up server script engine bindings 
2016.12.24 12:54:55 [WARN] JavaFX API isn't available 
2016.12.24 12:54:55 [INFO] JLine2 terminal enabled 
2016.12.24 12:54:55 [INFO] Reading RSA keypair 
2016.12.24 12:54:55 [INFO] Modulus CRC32: 0x87aed468 
2016.12.24 12:54:55 [INFO] Reading LaunchServer config file 
2016.12.24 12:54:55 [INFO] Fetching all AuthHandler entries 
2016.12.24 12:54:55 [INFO] HikariCP pooling enabled for 'authHandlerPool' 
[main] WARN com.zaxxer.hikari.HikariDataSource - idleTimeout is greater than maxLifetime, setting to maxLifetime. 
[main] INFO com.zaxxer.hikari.HikariDataSource - Hikari pool authHandlerPool is starting. 
2016.12.24 12:54:56 [ERROR] java.util.NoSuchElementException: message



#3 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 24 Декабрь 2016 - 22:06

Версия java какая?



#4 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 24 Декабрь 2016 - 22:11

Версия java какая?

Лаунчеру нужна восьмая, да и на машине стоит восьмая. (Но не уверен, как можно уточнить, что на машинке стоит восьмерка?)


Сообщение отредактировал aleksand1999: 24 Декабрь 2016 - 22:11


#5 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 24 Декабрь 2016 - 22:19

Лаунчеру нужна восьмая, да и на машине стоит восьмая. (Но не уверен, как можно уточнить, что на машинке стоит восьмерка?)

java -version



#6 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 24 Декабрь 2016 - 22:49

java -version

Да, верно. 1.8

 java -version
openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14)
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)


#7 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 24 Декабрь 2016 - 22:54

А у этого лаунчера нет GUI, случайно? 


JavaFX API isn't available - наверное, есть, если ему API JavaFX'a надо. Зачем это на сервере запускать?



#8 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 25 Декабрь 2016 - 19:42

А у этого лаунчера нет GUI, случайно? 


JavaFX API isn't available - наверное, есть, если ему API JavaFX'a надо. Зачем это на сервере запускать?

То есть надо установить JavaFX? Если да, то какой командой, ибо в инете не могу найти.



#9 Santiago

Santiago

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 5 052 сообщений

Отправлено 25 Декабрь 2016 - 21:45

То есть надо установить JavaFX? Если да, то какой командой, ибо в инете не могу найти.

Зачем вам GUI приложение на сервере?



#10 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 26 Декабрь 2016 - 5:59

Зачем вам GUI приложение на сервере?

Как написано на сайте разработчика лаунчера:
"Лаунчер написан на Java 8 с использованием технологии JavaFX, за счёт чего обладает широкими возможностями кастомизациибезупречной производительностью и отличным античитом"
Может именно поэтому он его хочет? Ибо я не понимаю, почему возникает ошибка.



#11 ykpon

ykpon

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 4 019 сообщений

Отправлено 26 Декабрь 2016 - 6:29

Как написано на сайте разработчика лаунчера:
"Лаунчер написан на Java 8 с использованием технологии JavaFX, за счёт чего обладает широкими возможностями кастомизациибезупречной производительностью и отличным античитом"
Может именно поэтому он его хочет? Ибо я не понимаю, почему возникает ошибка.

Может это лаунчер для игры и на сервере он не нужен?



#12 Santiago

Santiago

    Постоянный пользователь

  • Пользователь
  • PipPipPipPipPip
  • 5 052 сообщений

Отправлено 26 Декабрь 2016 - 9:36

Как написано на сайте разработчика лаунчера:
"Лаунчер написан на Java 8 с использованием технологии JavaFX, за счёт чего обладает широкими возможностями кастомизациибезупречной производительностью и отличным античитом"
Может именно поэтому он его хочет? Ибо я не понимаю, почему возникает ошибка.

Зачем лаунчер на сервере? о_О



#13 aleksand1999

aleksand1999

    Новичок

  • Пользователь
  • Pip
  • 14 сообщений

Отправлено 26 Декабрь 2016 - 13:51

Зачем лаунчер на сервере? о_О

 

Может это лаунчер для игры и на сервере он не нужен?

Извиняюсь, если это будет рекламой, но вот ссылка:
https://launcher.sashok724.net/
как я понял он на VDS ставиться, да и в видео под установку описывается как его на машинку ставят, но у меня это странная ошибка, вообще хз, если честно.



#14 nikitasew24

nikitasew24

    Новичок

  • Пользователь
  • Pip
  • 1 сообщений

Отправлено 26 Декабрь 2017 - 21:29

 

Добрый вечер, не подскажите ли, в чем заключается ошибка?
суть заключается, в том, что при прописывании команды:

 
root@vds772:~# cd /root/(Не важно)/

после чего:
 
root@vds772:~/sashok_v3# java -Xmx256M -jar LaunchServer.jar

Лаунчер начинает запускаться, но выдает ошибку: 
 
sashok724's LaunchServer v15.3 (build #34, 04.12.16)
2016.12.23 09:01:50 [INFO] Setting up server script engine bindings
2016.12.23 09:01:50 [WARN] JavaFX API isn't available
2016.12.23 09:01:50 [INFO] JLine2 terminal enabled
2016.12.23 09:01:50 [INFO] Reading RSA keypair
2016.12.23 09:01:50 [INFO]  Modulus CRC32: 0x87aed468
2016.12.23 09:01:50 [INFO] Reading LaunchServer config file
2016.12.23 09:01:50 [ERROR] java.io.IOException: Value start expected (line 31)
 
Не подскажите, как решить? Если надо что-то скачать, то пропишите команду, для скачивания. ;DD
Заранее, спасибо!
 

 

А как вы решили эту проблему, можете объяснить? (у меня просто такая же выскакивет)




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных